PCWorld Forums

PCWorld Forums: Dial-up Modems In Xp Mode - PCWorld Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Dial-up Modems In Xp Mode Can a dial-up modem be made functional within XP Mode?

#1 User is offline   RedGreenBlue 

  • Member
  • PipPip
  • Group: Members
  • Posts: 13
  • Joined: 04-December 09

Posted 11 January 2010 - 04:30 PM

Is it possible to get a dial-up modem to function with XP Mode in Windows 7 Professional 64-bit? I have a modem that is working fine directly in Windows 7 64-bit (it also will work in native Windows XP), but although XP mode will recognize the modem if I select it from a list or feed it the .inf file, it can't make the modem respond. If I install it as a standard 56K modem, it simply doesn't respond. If I have XP Mode install it using the manufacturer's driver (which is 32-bit), XP Mode correctly identifies the modem (an Agere Win Modem) but (correctly) indicates that it is nonfunctional.

I have an old but perfectly useful fax program, WinFax Basic Edition 10, that appears to install correctly in XP Mode (but is incompatible with Windows 7 64-bit) but not surprisingly can't find the fax modem. The Microsoft Windows 7 Support Center is light on how to install devices within XP Mode, though it's clear that some install quite smoothly, e.g., a networked HP printer. (I have the Windows Fax service working in Windows 7 itself, but it can't read my old fax files.)

Thanks to anyone who knows the answer, be it yes or no.
0

#2 User is offline   RedGreenBlue 

  • Member
  • PipPip
  • Group: Members
  • Posts: 13
  • Joined: 04-December 09

Posted 20 January 2010 - 02:35 PM

For those who are interested, here's the answer to the question, as provided by a helpful user on the Microsoft Answers Windows 7 forums:

"Internal modems are not accessible in XP Mode. XP Mode can acess physical COM ports on the host but not the virtual ones which internal modems install.

"You could use a USB modem, or an external serial port modem, and attach that to XP Mode."
0

#3 User is offline   Howdy 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 4
  • Joined: 20-February 10

Posted 20 February 2010 - 02:53 PM

I have done what you are attempting to do - and, yes it is possible. In fact, I have WinFax Pro 8 and it is working (and, yes, faxing) perfectly in Window 7 XP mode.

You need to go to settings in xp mode and click on com 1 or com 2 and then select physical port (com 3 on mine).

From there I just set up the modem within WinFax.

If yo are still interested in doing this and have difficulty, reply and I'll try to walk you through what I did. But you can definitely do it!
0

#4 User is offline   RedGreenBlue 

  • Member
  • PipPip
  • Group: Members
  • Posts: 13
  • Joined: 04-December 09

Posted 21 February 2010 - 08:24 AM

Howdy, Thank you.

This is very interesting. I'm not very familiar with Windows XP because I jumped directly to Windows 7 from Windows 2000, so please bear with me. If I understand your instruction correctly, I need to go into the ports section of Device Manager and reset COM2 to be COM3 (where my modem resides in Windows 7). If that's right, I was unable to do it because making that change requires write privileges for the registry (according to the denial-of-access message I got when I clicked the Advanced button). Presumably, I should log on as Administrator to overcome that, but I don't know the secret of logging onto XP Mode as Administrator. When I try to, it rejects the only password I set for XP Mode--and won't log on with the password field blank either. (I could edit the registry directly, but COM2 appears there too many times for me to be able to figure out all the instances that should be changed.)

I tried running both Virtual PC and XP Mode as Administrator, but that didn't help. How did you do it? Or should I be using some other function in Control Panel to modify the port settings?

Thank you.
0

#5 User is offline   Howdy 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 4
  • Joined: 20-February 10

Posted 24 February 2010 - 04:04 PM

I did not do anything through Windows 7 - I believe it was all configured from within XP mode. I have attached an image, which you can hopefully see, to show you the settings. With XP Mode running, but not maximized, you will be able to see the bar at the top of the XP window which will have a "tools" tab. Click on that and you will then see the "settings" tab. Click on that and it will bring up the settings window as per the attachment. I have attached XP mode's virtual com2 port to the physical port com3 and then checked "wait for modem command to open port" - then close the windows save settings and, I believe you will need to re-start XP Mode for the settings to take effect. These settings will now allow XP mode to "see" the actual modem on your PC.

The next step is to then set up the modem in WinFax. I would think that the procedure in WinFax 8 and 10 should be similar. Here is where I am not certain of what I did. I know that within WinFax I went to "setup, then "modem" then "add modem" and chose regular modem. I navigated through these (and other) dialog boxes until I finally succeeded in installing the modem. In my case, I always chose 14,400 as the speed and hardware flow (this choice you can confirm from your modem's settings in Windows 7's device manager).

If you keep at it and are persistent knowing that it can be done, I am sure you will succeed. Please let me know how you make out and I'll be glad to assist you further if it will help.

Good luck!

Attached thumbnail(s)

  • Attached Image: settings.jpg

0

#6 User is offline   RedGreenBlue 

  • Member
  • PipPip
  • Group: Members
  • Posts: 13
  • Joined: 04-December 09

Posted 25 February 2010 - 08:50 PM

Thank you, Howdy. It will be no surprise to you that your instructions worked. I had to mess around a little to get the modem correctly installed within XP Mode, but once I did that, it was no trouble configuring it in WinFax. Then I copied over my WinFax data folder from my W2K OS and had all my saved faxes available as well.

My biggest issue was realizing that the modem's showing in XP Mode as being installed on COM2 was correct. I tried to find COM3 for it at first.

Thanks again. Now I will need to enlighten the gentleman in the Microsoft-owned forums as to this technique. Most excellent.
0

#7 User is offline   Howdy 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 4
  • Joined: 20-February 10

Posted 26 February 2010 - 06:28 PM

I am glad it worked for you - I knew you'd do it. Forums are really a great place to find out these little pearls which probably should be more straightforward in the first place. It's also amazing to me that many of these old programs are still worth keeping around and, thanks to XP mode, we can still use them.
0

#8 User is offline   RedGreenBlue 

  • Member
  • PipPip
  • Group: Members
  • Posts: 13
  • Joined: 04-December 09

Posted 28 February 2010 - 06:30 AM

We're in total agreement.
0

#9 User is offline   RedGreenBlue 

  • Member
  • PipPip
  • Group: Members
  • Posts: 13
  • Joined: 04-December 09

Posted 26 August 2010 - 07:06 AM

An inquiry from a member led me to review this thread and consequently realize that due to the back-and-forth way the information is presented, the steps for getting a dial-up/fax modem recognized in XP Mode are not laid out clearly. Following is a hopefully clearer restatement of them:

To get your physical modem recognized in XP mode you don't need to install any drivers in XP Mode. Whatever default Microsoft modem drivers XP Mode installs seem to be all that are necessary and are probably are in fact required. I don't think that a manufacturer's proprietary drivers for a modem will work within XP Mode (as opposed to in Windows 7). They didn't for me--they appeared to install, but the modem they enabled to be listed in XP Mode's modem list couldn't be selected by my faxing software. I think the reason is that the Virtual PC provides its own interface between the Windows 7 drivers and the XP drivers. (This all assumes that your modem is operating correctly in Windows 7 itself; that is a prerequisite.)

To attach the modem to the correct COM port in XP Mode, you need to get into the Settings menu for the Windows Virtual PC (not XP mode itself) by either starting the Virtual PC without starting XP Mode or when in XP Mode, exiting the full screen view by clicking on the two squares in the upper right-hand corner of the screen (the familiar restore button between close and minimize--X and -). There you will find a menu bar with a "Tools" drop-down menu. The choices are "Disable Integration Features" and "Settings." Click on "Settings," of course.

When you open "Settings," you will find a window on the left with a list of devices, hard drives, COM ports, and a few others. One of them, presumably COM2, will be listed as a physical serial port. Select that one to modify. Then select the physical serial port option for that COM port in the window that appears on the right half of the Virtual PC screen, next select from the drop-down list the COM port your modem is actually using in Windows 7, and lastly check the box that says "Wait for modem command to open port." Click OK and exit the Settings dialog box by clicking OK. (My guess is the Microsoft documentation for this is found in reference to Windows Virtual PC and not XP Mode. I certainly didn't see it in any of the XP Mode how-to materials.)

I don't recall if this is necessary, but I would now restart XP mode. Then go to "Phone and Modem Options" in Control Panel in XP Mode and install the standard modem (that is, the generic modem) for the correct speed (matching the speed of your actual modem) and be sure it is assigned to COM2 (or whichever COM port was listed as the physical serial port in the Virtual PC Settings). Be sure that you have uninstalled any modem you may have previously attempted to install before you do this, otherwise the failed installation may block or interfere with installing the standard modem. At this point, you can install (or configure) your fax or other software requiring a modem in the same manner you would if it were running in a physical machine running Windows XP, remembering that you will be using the standard modem attached to the physical-serial-port COM port (probably COM2). This, of course, may also require restarts of XP Mode.
0

#10 User is offline   FarmerKarl 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 03-January 11

Posted 03 January 2011 - 10:58 AM

View PostRedGreenBlue, on 26 August 2010 - 07:06 AM, said:

An inquiry from a member led me to review this thread and consequently realize that due to the back-and-forth way the information is presented, the steps for getting a dial-up/fax modem recognized in XP Mode are not laid out clearly. Following is a hopefully clearer restatement of them:

To get your physical modem recognized in XP mode you don't need to install any drivers in XP Mode. Whatever default Microsoft modem drivers XP Mode installs seem to be all that are necessary and are probably are in fact required. I don't think that a manufacturer's proprietary drivers for a modem will work within XP Mode (as opposed to in Windows 7). They didn't for me--they appeared to install, but the modem they enabled to be listed in XP Mode's modem list couldn't be selected by my faxing software. I think the reason is that the Virtual PC provides its own interface between the Windows 7 drivers and the XP drivers. (This all assumes that your modem is operating correctly in Windows 7 itself; that is a prerequisite.)

To attach the modem to the correct COM port in XP Mode, you need to get into the Settings menu for the Windows Virtual PC (not XP mode itself) by either starting the Virtual PC without starting XP Mode or when in XP Mode, exiting the full screen view by clicking on the two squares in the upper right-hand corner of the screen (the familiar restore button between close and minimize--X and -). There you will find a menu bar with a "Tools" drop-down menu. The choices are "Disable Integration Features" and "Settings." Click on "Settings," of course.

When you open "Settings," you will find a window on the left with a list of devices, hard drives, COM ports, and a few others. One of them, presumably COM2, will be listed as a physical serial port. Select that one to modify. Then select the physical serial port option for that COM port in the window that appears on the right half of the Virtual PC screen, next select from the drop-down list the COM port your modem is actually using in Windows 7, and lastly check the box that says "Wait for modem command to open port." Click OK and exit the Settings dialog box by clicking OK. (My guess is the Microsoft documentation for this is found in reference to Windows Virtual PC and not XP Mode. I certainly didn't see it in any of the XP Mode how-to materials.)

I don't recall if this is necessary, but I would now restart XP mode. Then go to "Phone and Modem Options" in Control Panel in XP Mode and install the standard modem (that is, the generic modem) for the correct speed (matching the speed of your actual modem) and be sure it is assigned to COM2 (or whichever COM port was listed as the physical serial port in the Virtual PC Settings). Be sure that you have uninstalled any modem you may have previously attempted to install before you do this, otherwise the failed installation may block or interfere with installing the standard modem. At this point, you can install (or configure) your fax or other software requiring a modem in the same manner you would if it were running in a physical machine running Windows XP, remembering that you will be using the standard modem attached to the physical-serial-port COM port (probably COM2). This, of course, may also require restarts of XP Mode.

0

#11 User is offline   FarmerKarl 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 03-January 11

Posted 03 January 2011 - 11:36 AM

This is an excellent post and helped me get Win Fax Pro 10.02 working within a 64 bit Windows 7 "XP mode" with a US Robotics USR56510C internal modem. I have a newer ASUS mother board that does not have a serial port so I chose in Jan 2010 to purchase an internal modem blissfully unaware of the fact (according to MS support) that "internal modems" don't work in Win 7's XP mode.

After spending several hours in early January 2010 tying to get WinFax working in XP Mode I gave up. I revisted this issue just a few days ago and was pleased that someone did not take "no" for an answer. Great Job in documenting the steps!

I did have some trouble getting the WinFax program to work with my Epson 3200 Twain scanner and had to eliminate resource conflicting "junk programs" like Windows 7 Fax and Scan, Windows XP Fax, and various FAX printer drivers that inhibited the "send" step....but in the end it worked--Not as smoothly as in my old Win XP machine, but it finally works enough to send the occasional FAX.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users